How-to: Use USB Audio in Retropie v3.7

Various user-contributed guides for software-related things
jellypowered
Posts: 35
Joined: Mon Dec 05, 2016 10:14 pm
Has thanked: 13 times
Been thanked: 10 times

Re: How-to: Use USB Audio in Retropie v3.7

Post by jellypowered » Sun Mar 19, 2017 3:47 pm

Fleder wrote:
drlbradley wrote:Let me know if you get audio out of the emulators. I can get audio from emulationstation Ui, but not from any emulators
Could you try the following, please?:

Create the .asoundrc file. Which should not exist.

Code: Select all

sudo nano .asoundrc
Then type in the following (if your device is card 0 and device 0 (/proc/asound/cards)):

Code: Select all

pcm.PCM {
	type hw
	card 0
	device 0
}
Strg+X -> Yes -> Enter

Code: Select all

sudo reboot
This should create an alias for your mixer which is usually called "Speaker".
But as Alsamixer is looking for PCM, this causes it to ignore that one.
Was having similar issues with the "Failed to find mixer elements"
Lsusb showed my device was "6"
So i followed your instructions and replaced device 0 with device 6 and the warning went away and am able to control volume through Emulationstation. Thanks a ton!

negrete35
Posts: 23
Joined: Fri Mar 31, 2017 11:52 am
Has thanked: 10 times
Been thanked: 1 time

Re: How-to: Use USB Audio in Retropie v3.7

Post by negrete35 » Sun Apr 16, 2017 7:33 pm

How are the commands typed using a US keyboard? Haha

jellypowered
Posts: 35
Joined: Mon Dec 05, 2016 10:14 pm
Has thanked: 13 times
Been thanked: 10 times

Re: How-to: Use USB Audio in Retropie v3.7

Post by jellypowered » Mon Apr 17, 2017 10:35 pm

You have to set your local in retropie setup to us.

negrete35
Posts: 23
Joined: Fri Mar 31, 2017 11:52 am
Has thanked: 10 times
Been thanked: 1 time

Re: How-to: Use USB Audio in Retropie v3.7

Post by negrete35 » Tue Apr 18, 2017 3:21 pm

jellypowered wrote:
Mon Apr 17, 2017 10:35 pm
You have to set your local in retropie setup to us.
I got what I needed figured out. I just stumbled across this thread while trying to find the help i needed. But while trying to follow, I discovered that the placement of the '@' is on another key. Found that, but could not end up finding the '~' so I had to give up on this, couldnt follow this guide. haha. I will look at adjusting the location though. Thank you.

TheDood
Posts: 2
Joined: Fri Apr 21, 2017 11:23 pm
Been thanked: 1 time

Re: How-to: Use USB Audio in Retropie v3.7

Post by TheDood » Thu Apr 27, 2017 3:22 pm

Robvp wrote:
Fri May 13, 2016 4:27 pm
How is the sound quality and volume compared to the pi's sound?

I'm currently debating wether to use this or get the output from the pi
I've only tried the usb method with my Zero. The audio is a bit garbled at times. Not sure what the issue is with that though, but it's usable.

User avatar
VeteranGamer
Posts: 866
Joined: Thu Jan 26, 2017 11:12 am
Location: London, UK
Has thanked: 229 times
Been thanked: 442 times

Re: How-to: Use USB Audio in Retropie v3.7

Post by VeteranGamer » Wed Jul 26, 2017 4:32 am

i've tried to build the code....

but i keep hitting the same issue...

it always kinda freezes/stops at 24%

building cxx object es-core/cmakefiles/es-core.dir/srs/components/helpcomponent.cpp.o


not sure if this has happend to others of am i doing something wrong...

could it also be an issue because i have retropie 4.2

User avatar
redled
Posts: 27
Joined: Mon Aug 14, 2017 4:40 pm
Location: San Francisco
Has thanked: 35 times
Been thanked: 3 times

Re: How-to: Use USB Audio in Retropie v3.7

Post by redled » Fri Sep 01, 2017 11:42 am

Can we simply disable

Code: Select all

snd_bcm2835
and not bother changing the order of the USB and native device?

ZodiaX69
Posts: 1
Joined: Fri Sep 08, 2017 2:25 am

Re: How-to: Use USB Audio in Retropie v3.7

Post by ZodiaX69 » Sat Sep 30, 2017 6:34 pm

I originally used this guide to set up USB audio and it worked well except for the "VolumeControl::init() - Failed to find mixer elements!" error kept appearing every time I quit a game.

I found this guide https://www.woltersadvertising.com/how- ... -retropie/ which worked perfect for me and now I no longer get the VolumeControl::init() - Failed to find mixer elements! error.

Hoshosslehoff
Posts: 2
Joined: Wed Oct 18, 2017 1:11 pm

Re: How-to: Use USB Audio in Retropie v3.7

Post by Hoshosslehoff » Mon Oct 30, 2017 2:56 pm

Is there a way to reverse this process back to original default?

boquetipo
Posts: 8
Joined: Thu Jul 13, 2017 7:25 am
Location: Spain
Has thanked: 4 times

Re: How-to: Use USB Audio in Retropie v3.7

Post by boquetipo » Sun Nov 19, 2017 2:39 am

Despite the sound sounds well, when changing to console mode, the message "(snd_pcm_recover) underrun occurred" shows several times.
Is that a problem? Anyone has the same message?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest