Search found 13 matches

by parizene
Wed Jan 02, 2019 11:56 am
Forum: Support for Kite's Products
Topic: LCD blinking
Replies: 1
Views: 175

LCD blinking

I soldered my Circuit Sword Lite and have an issue. Display blinks and I can hear tick sound on every blink. Frequency of blinking is increasing with time. Touching BL_ON area stops blinking for some seconds, the area is very hot. Any suggestions? https://drive.google.com/file/d/1xmyilV99QW30bBFzqr5...
by parizene
Sun Oct 28, 2018 2:29 pm
Forum: Guides
Topic: [Guide] ili9341 SPI TFT Screen on Retropie
Replies: 256
Views: 88176

Re: [Guide] ili9341 SPI TFT Screen on Retropie

facelessloser wrote:
Sun Oct 28, 2018 9:49 am
Oh so you couldn't get it to work on the breakout board but could on the bare screen?
yes
by parizene
Sun Oct 28, 2018 9:27 am
Forum: Guides
Topic: [Guide] ili9341 SPI TFT Screen on Retropie
Replies: 256
Views: 88176

Re: [Guide] ili9341 SPI TFT Screen on Retropie

Thanks for posting this, Ive tried out your commands but with a screen on a breakout board like this one https://www.aliexpress.com/item/1-3-Inch-IPS-OLED-Display-Module-240-240-RGB-TFT-for-Arduino-DIY-LCD-Board/32880670572.html?spm=2114.search0104.3.16.693374747K6Ddc&ws_ab_test=searchweb0_0,search...
by parizene
Thu Oct 25, 2018 9:26 am
Forum: Guides
Topic: [Guide] ili9341 SPI TFT Screen on Retropie
Replies: 256
Views: 88176

Re: [Guide] ili9341 SPI TFT Screen on Retropie

I have DC pin, I don't have CS pin Hey I know this is a old post but did anyone get the 1.3" st7789v screen working, I'm really struggling. I did message waveshare about their hat they make which has the same screen https://www.waveshare.com/1.3inch-lcd-hat.htm, They sent me this on how to get it w...
by parizene
Sun Sep 02, 2018 8:15 am
Forum: Guides
Topic: [Guide] ili9341 SPI TFT Screen on Retropie
Replies: 256
Views: 88176

Re: [Guide] ili9341 SPI TFT Screen on Retropie

I have DC pin, I don't have CS pin
by parizene
Sun Sep 02, 2018 3:13 am
Forum: Guides
Topic: [Guide] ili9341 SPI TFT Screen on Retropie
Replies: 256
Views: 88176

Re: [Guide] ili9341 SPI TFT Screen on Retropie

moosepr wrote:
Sat Sep 01, 2018 5:10 pm
Ah ok, not the screen I thought it was.

Can you probe the ribbon and the pins to prove the PCB is correct?
yeah, already did this, seems to be ok. maybe smth wrong with a driver I'm using
but I saw this image on aliexpress
SpoilerShow
Image
by parizene
Sat Sep 01, 2018 11:38 am
Forum: Guides
Topic: [Guide] ili9341 SPI TFT Screen on Retropie
Replies: 256
Views: 88176

Re: [Guide] ili9341 SPI TFT Screen on Retropie

If it's the screen I think it is, the silkscreen is wrong! Try RPI Display 3,3V(Pin1) VCC Ground(Pin6) GND MOSI(12,Pin19) SDA n/a SCK CE0(10,Pin24) CS SCLK(14,Pin23) A0 25(Pin37) RESET Then your modprobe line should get you something. The built in driver has the colours flipped, but we can fix that...
by parizene
Thu Aug 30, 2018 2:41 am
Forum: Guides
Topic: [Guide] ili9341 SPI TFT Screen on Retropie
Replies: 256
Views: 88176

Re: [Guide] ili9341 SPI TFT Screen on Retropie

KonnorJ wrote:
Thu Aug 30, 2018 2:28 am
You're images aren't working parizene
thanks, updated
by parizene
Thu Aug 30, 2018 1:53 am
Forum: Guides
Topic: [Guide] ili9341 SPI TFT Screen on Retropie
Replies: 256
Views: 88176

Re: [Guide] ili9341 SPI TFT Screen on Retropie

Wiring https://image.ibb.co/fdeDsp/20180830_010950.jpg 240x240 (not working), does not have CS pin sudo modprobe fbtft_device name=fb_st7789v gpios=reset:25,dc:24,led:23 speed=40000000 custom=1 fps=60 https://image.ibb.co/dvxBdU/20180830_011046.jpg [ 90.415414] fbtft: module is from the staging dire...
by parizene
Tue Aug 07, 2018 6:14 am
Forum: Guides
Topic: [Guide] ili9341 SPI TFT Screen on Retropie
Replies: 256
Views: 88176

Re: [Guide] ili9341 SPI TFT Screen on Retropie

Ah ok, maybe you need the v then. Have you checked dmesg to see if it's actually loading the driver first? yeah, driver is loading according to dmesg, but actually only black screen with backlight on display all the time, fb0 & fb1 are listed in /dev. con2fbmap does nothing. probably smth is missing