Display not working

Having trouble with your mintyPi build? Post your questions here!
Post Reply
snizzletoff
Posts: 6
Joined: Mon Feb 19, 2018 7:27 pm
Has thanked: 1 time

Display not working

Post by snizzletoff » Wed May 09, 2018 9:40 am

Hello All, i am hoping someone can give me some ideas as to what my issue might be. As the title suggests i am not getting any output to my screen, its not turning on or turning white or anything.

I have tested continuity between all of the test pads and the raspberry pi has full continuity to every test pad and the button PCB.

What i do noticed is that the raspberry pi or button PCB DO NOT have continuity to SCL on the back of the screen though. Should i try a jumper wire to the screen?

I didn't have an HDMI mini to test the pi with prior to soldering so i used the analog out, it worked perfectly fine and booted before soldering. I will also try to test analog out again tonight, but wondering if there is something else i am missing.

I really appreciate any input or guidance! Thanks all!
Attachments
IMAG2499.jpg
IMAG2499.jpg (2.93 MiB) Viewed 523 times
IMAG2498.jpg
IMAG2498.jpg (3.35 MiB) Viewed 523 times

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2359
Joined: Thu May 05, 2016 8:33 am
Location: Fall River, MA
Has thanked: 1249 times
Been thanked: 2880 times

Re: Display not working

Post by Helder » Wed May 09, 2018 11:33 am

Are you using the mintyPi SD image on the SD card? Have you done a continuity from the GPIO to the test pads on the LCD board? Are you getting voltage on the LCD board?
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

snizzletoff
Posts: 6
Joined: Mon Feb 19, 2018 7:27 pm
Has thanked: 1 time

Re: Display not working

Post by snizzletoff » Wed May 09, 2018 1:57 pm

Hello and thank you for the reply.

Yes i am using mintyPI image on the SD card. I used Etcher to install, and confirmed the PI and image are working normally prior to soldering but i used analog out. I plan to test analog out again this evening.

Yes, everything has continuity at the screen other than SCL. everything else is normal, and its receiving 3.3v at the VCC pad on the screen.

I will go through every pad again tonight, it has been a few days since i poked around with it. I thought it was my soldering but i tested each connection as i did it. and SCL between the two boards (pi and pcb) are fine. Also tested continuity of all the wires in the ribbon cable, no issues there.

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2359
Joined: Thu May 05, 2016 8:33 am
Location: Fall River, MA
Has thanked: 1249 times
Been thanked: 2880 times

Re: Display not working

Post by Helder » Wed May 09, 2018 10:53 pm

Try adding a little solder to each ribbon connector's pins, might have a weak joint on one of them.
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

snizzletoff
Posts: 6
Joined: Mon Feb 19, 2018 7:27 pm
Has thanked: 1 time

Re: Display not working

Post by snizzletoff » Thu May 10, 2018 8:24 am

Thanks for the suggestion. I will go ahead and try that this evening and let you know what happens!!

snizzletoff
Posts: 6
Joined: Mon Feb 19, 2018 7:27 pm
Has thanked: 1 time

Re: Display not working

Post by snizzletoff » Thu May 10, 2018 5:45 pm

Thank you for the suggestion, a bit of solder on the cable did the trick for me. Thank you sir!!!
Attachments
32256423_1934601213239607_7097708046784135168_n.jpg
32256423_1934601213239607_7097708046784135168_n.jpg (271.95 KiB) Viewed 460 times

Mr Hazim
Posts: 1
Joined: Fri Feb 23, 2018 4:50 pm

Re: Display not working

Post by Mr Hazim » Thu Jul 12, 2018 10:15 am

Hi, I am having this exact problem.
So even when you had continuity from PCB to LCD I might still get no video? I haven't tested this in my board yet, but I got an HDMI mini and my board shows video.
I will try adding solder to the ribbon tonight, and try again.

Edit: My Ground soldering was filing :? I got it to work now :D

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests