Sound error code

Having trouble with your mintyPi build? Post your questions here!
Post Reply
J-Malice
Posts: 55
Joined: Fri Jun 02, 2017 2:40 pm
Has thanked: 33 times
Been thanked: 8 times

Sound error code

Post by J-Malice » Tue Nov 07, 2017 12:47 pm

VolumeControl::init() - Failed to find mixer elements!

That is the error I am receiving on top of not having any volume from games or in menus. I found this thread discussing the issue about retropie = https://github.com/Aloshi/EmulationStation/issues/433

And it is a little confusing but I think I get the gist of it. My question, would recompiling the retropie source like they recommend have any adverse affect on the mintypi specific changes made to the software? Is it even possible for me to do this? It is there a simpler solution to this I am not seeing?

Thanks for any help.

User avatar
dryja123
Posts: 1064
Joined: Tue May 09, 2017 5:34 pm
Location: Central NJ
Has thanked: 232 times
Been thanked: 552 times

Re: Sound error code

Post by dryja123 » Tue Nov 07, 2017 2:41 pm

If your sound card is connected properly, and is in good working condition, it should work when you play a game. I would reflash your SD card with the mintyPi image. If that doesn't work check your connections and try a new card if it doesn't work.

Sw0rd
Posts: 6
Joined: Thu Oct 18, 2018 9:29 pm
Been thanked: 11 times

Re: Sound error code

Post by Sw0rd » Wed Jun 19, 2019 4:47 pm

Hi all,

I'm putting together a recently recieved V3 and I'm getting this error as well.... VolumeControl::init() - Failed to find mixer elements!

No sound in menu or game. All connections seem to be ok. Could it be a bad speaker? In the menu for audio, it defaults to PCM and when putting it to speaker, the volume is at 0% and after cranking it up to 100% and leaving the menu and coming back to the menu, it's back at 0% again. Anytime a audio event is supposed to happen, it shows that error.

I issued this at the terminal also... sudo chown -R pi:pi /opt/retropie/configs

Thanks for any info. I'm an older guy that likes to tinker with this stuff, but my hands and eyes are failing me. I may have to have someone check this for me if I can't get it figured out. Everything else seems to work.

Scott

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2915
Joined: Thu May 05, 2016 8:33 am
Location: Rogers, AR
Has thanked: 1447 times
Been thanked: 3098 times

Re: Sound error code

Post by Helder » Wed Jun 19, 2019 10:54 pm

I would double check the 5v point and the 3 audio gpio for proper continuity. If any of those 4 points have a bad connection audio will not work.
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

Sw0rd
Posts: 6
Joined: Thu Oct 18, 2018 9:29 pm
Been thanked: 11 times

Re: Sound error code

Post by Sw0rd » Thu Jun 20, 2019 10:14 am

Thanks, checked those and all appears to be ok.

It would appear that I buggered the speaker itself by mistakenly connecting to the inner pads and then changing it to the outer pads as it should be and possibly somehow damaging the tiny wire that I can't see there. Tried a GBZ speaker I had and it works now, although that error still happens between selecting/returning from a Retropi option as well as when starting a game. VolumeControl::init() - Failed to find mixer elements!

A suggestion for future versions, possibly move the speaker connections on the board so that when assembled, the pads of both the speaker and board aren't right on top of each other leaving a very close to no gap between them.

Ordered a couple replacement speakers off EBay. ;)

Scott

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest