Its not powering on

Having trouble with your mintyPi build? Post your questions here!
Shade
Posts: 15
Joined: Thu Nov 16, 2017 5:45 pm
Been thanked: 1 time

Its not powering on

Post by Shade » Sun Jan 07, 2018 11:27 pm

After soldering everything I tested all the connections and they were good, and inserted the sd card with the softwear, but nothings happening. the green light dosent turn on when i plug it in either. This is my first time doing anything like this and I dont know whats wrong.
I attached pictrues of the motherboard.
Attachments
IMG_0100.JPG
Picture of my motherboard#1
IMG_0100.JPG (2.54 MiB) Viewed 941 times
IMG_0099.JPG
Picture of my motherboard#2
IMG_0099.JPG (3.02 MiB) Viewed 941 times

sygyzy
Posts: 175
Joined: Tue Sep 05, 2017 12:45 pm
Has thanked: 56 times
Been thanked: 25 times

Re: Its not powering on

Post by sygyzy » Mon Jan 08, 2018 12:14 am

How do you have it powered? Which microUSB port did you plug into? Where did you get the image? How did you flash it?

User avatar
YaYa
Posts: 1965
Joined: Mon Jun 26, 2017 12:42 pm
Location: brittany - France
Has thanked: 913 times
Been thanked: 814 times
Contact:

Re: Its not powering on

Post by YaYa » Mon Jan 08, 2018 7:20 am

Plug the SD on the with a basic retropie and power it via its own micro usb while outputting video via its own hdmi just to see it the pi is not fried.
When i see your soldering, i’m afraid :o

Your iron was really too hot :?

User avatar
rodocop
Posts: 1226
Joined: Mon Aug 22, 2016 3:14 pm
Location: Saskatchewan
Has thanked: 490 times
Been thanked: 433 times

Re: Its not powering on

Post by rodocop » Mon Jan 08, 2018 7:26 am

Did you test the pi before soldering? Seems odd that the LED does not shine when the pi is plugged in. Double check that you have the proper V4 image from the wiki, and a good power supply.

Also, make sure you test the continuity of all GPIO's and the corresponding test pads. When you plug the pi in are you getting any voltage readings on the PCB?

User avatar
YaYa
Posts: 1965
Joined: Mon Jun 26, 2017 12:42 pm
Location: brittany - France
Has thanked: 913 times
Been thanked: 814 times
Contact:

Re: Its not powering on

Post by YaYa » Mon Jan 08, 2018 8:47 am

I would advise you to first follow my advice to see if the Pi itself is working (bypass everyting from Helder’s board) then follow Rodocop’s advice.

Don’t waste your time to try to figure out what’s wrong if the problem is the Pi itself

Shade
Posts: 15
Joined: Thu Nov 16, 2017 5:45 pm
Been thanked: 1 time

Re: Its not powering on

Post by Shade » Mon Jan 08, 2018 9:21 pm

I tried bypassing it with a hdmi but still nothing happened. The green light still wont turn on. Its dead. Is there a safe way to remove it from the board? Also the power supply is good. I used the same one I used to test the pies before i soldered.
Attachments
IMG_0101.JPG
IMG_0101.JPG (2.5 MiB) Viewed 909 times

User avatar
YaYa
Posts: 1965
Joined: Mon Jun 26, 2017 12:42 pm
Location: brittany - France
Has thanked: 913 times
Been thanked: 814 times
Contact:

Re: Its not powering on

Post by YaYa » Mon Jan 08, 2018 11:12 pm

One more test to go : use the same SD with the same image on another Pi to see if it’s not a faulty SD card, or try another SD.

It is still possible that you have a bridge between ground and power under the Pi so don’t give up now !

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2236
Joined: Thu May 05, 2016 8:33 am
Location: Fall River, MA
Has thanked: 1160 times
Been thanked: 2798 times

Re: Its not powering on

Post by Helder » Mon Jan 08, 2018 11:23 pm

I'm pretty sure you have power grounded. Use a multimeter and test continuity from VCC to any GND pad, if there's continuity there is your problem.

What kind of soldering iron tip are you using? You could've put too much solder on the 5v GPIO and it spread to the GND GPIO to the left of it.
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

Shade
Posts: 15
Joined: Thu Nov 16, 2017 5:45 pm
Been thanked: 1 time

Re: Its not powering on

Post by Shade » Wed Jan 10, 2018 4:22 pm

Here's what I've done. I don't have another rasberry pi to test the sd card on, but I did check the continuity between the VCC and GND and I belive theres no continuity between them. I posted pictures of what i did to make sure I tested everything correctly. Also the soldering iron I used is shown here.
Attachments
IMG_0104.JPG
IMG_0104.JPG (2.35 MiB) Viewed 891 times
IMG_0105.JPG
IMG_0105.JPG (2.33 MiB) Viewed 891 times
IMG_0103.JPG
IMG_0103.JPG (2.6 MiB) Viewed 891 times

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2236
Joined: Thu May 05, 2016 8:33 am
Location: Fall River, MA
Has thanked: 1160 times
Been thanked: 2798 times

Re: Its not powering on

Post by Helder » Wed Jan 10, 2018 11:58 pm

It looks like there's some continuity between VCC and GND in that pic, using a digital multimeter is easier to determine this. Test VCC and GND on the controller pcb also, and that iron tip doesn't look like it'll do a good job soldering the Pi to the pcb so again a cheap digital multimeter is best to test these connections.

Harbor Freight has digital multimeters for like $6 have a look at one. And the picture above looks like there's no SD card inserted in the Pi.
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests