Page 1 of 1

SD cartridge reader sortof works...

Posted: Sun Jun 19, 2016 3:20 pm
by petran1420
Hello friends,

I just whipped up my first attempt at the cartridge extend-o-sd, using prerunnerseth's cartridge pcb (so intereference shouldn't be a problem). I wired everything up, and when I try to boot up, I get a signal to my hdmi screen I'm temporarily using, but I believe theres an error during boot. I've attached the screenshots from my 2 times trying to boot up.
IMG_20160619_160508756_HDR.jpg
IMG_20160619_160508756_HDR.jpg (297.32 KiB) Viewed 2570 times
IMG_20160619_160633605.jpg
IMG_20160619_160633605.jpg (362.15 KiB) Viewed 2570 times
Any suggestions? Did I not wire them up correctly? I added shrink tubing around each pin on the cartridge reader to make sure none of the wires were touching, and it boots up just fine using the sd slot built into the pi.

Re: SD cartridge reader sortof works...

Posted: Mon Jun 27, 2016 5:15 pm
by Kilren
petran1420 wrote:Hello friends,

I just whipped up my first attempt at the cartridge extend-o-sd, using prerunnerseth's cartridge pcb (so intereference shouldn't be a problem). I wired everything up, and when I try to boot up, I get a signal to my hdmi screen I'm temporarily using, but I believe theres an error during boot. I've attached the screenshots from my 2 times trying to boot up.

Any suggestions? Did I not wire them up correctly? I added shrink tubing around each pin on the cartridge reader to make sure none of the wires were touching, and it boots up just fine using the sd slot built into the pi.
Have you tried a different micro SD yet? I'd start there and see if it is the SD fault, or hardware fault.

Re: SD cartridge reader sortof works...

Posted: Mon Jun 27, 2016 6:55 pm
by petran1420
Have you tried a different micro SD yet? I'd start there and see if it is the SD fault, or hardware fault.
I actually had 2 SD cards and 2 cartridge pcbs. I tried all 4 combinations and one of them works, unfortunately its my 4GB card and not my 8GB card, blergh!

Even then, sometimes it doesn't boot and gives me the 'problem switching to high speed mode' warning. I may have to just forego this and use the rPi0 sd card reader...

Re: SD cartridge reader sortof works...

Posted: Tue Jun 28, 2016 12:47 pm
by DirtyBullets
do you have any pics or plans how you wired it in cos maybe one of the data lines is off :?:

Re: SD cartridge reader sortof works...

Posted: Tue Jun 28, 2016 9:39 pm
by petran1420
http://imgur.com/a/UtSWs

Not sure if thats any help. I apologize for reusing wire colors, I know its not best practice!

Re: SD cartridge reader sortof works...

Posted: Tue Jun 28, 2016 10:40 pm
by DirtyBullets
petran1420 wrote:http://imgur.com/a/UtSWs

Not sure if thats any help. I apologize for reusing wire colors, I know its not best practice!
I can see some "what we call it as dry solder" if you have any flux just wipe some over the solder and melt the solder, This should give it better connection, also you may want to try and shorten the exposed wire like your video wire is touching ground,

lastly...why is that red wire for? that is coming from the 5V