Circuit Sword Screen Issues.

Having trouble with your GBZ build? Ask your questions here!
Post Reply
Posts: 22
Joined: Mon Jun 18, 2018 2:41 pm
Has thanked: 1 time
Been thanked: 3 times

Circuit Sword Screen Issues.

Post by eyefire » Mon Mar 21, 2022 5:33 pm

Quick version - four different screens, two different SDcards, and two different CM3 modules - the screen is not working on any, and working differently in different configurations.

I have had a Circuit Sword for years, recently decided to upgrade it to the boxy pixel case, and when I disassembled it on the of the pieces that holds down the ribbon cable broke. I was also missing the original HDMI board.

So I went ahead and ordered a new complete kit with kite's last preorder. I just got home from traveling and have been trying to get it working, but the screen is giving me issues.

Going through the process on github all the LEDs were working correctly. I burned the newest software to a 256gb SD card using balenaEtcher (mac). I edited config-sc.txt to change to the tester mode.

when I turn it on I get a bunch of lines on the screen:
IMG_5230.jpeg (3.17 MiB) Viewed 35615 times
It is booting up, and when I flip the power switch and turns off.

I have two of these monitors with the Green Tabs (newest version I believe) - so I tried the second monitor, exact same issue. I tried my old SD card from my previous Circuit Sword Build - Same/similar issue.

I also tried swapping out the CM3 with my old one, same issue.

Now if i try to boot it up with the old screen, and newly flashed SD card I get this:
IMG_5231.jpeg (3.24 MiB) Viewed 35615 times
If I use my old SD card attached to the old screen, it boots up but it looks really blown out / low saturation
IMG_5232.jpeg (3.55 MiB) Viewed 35615 times
I finally realized I have a third screen, this one has a red tab on the screen protector (I thought I bought the extra monitors a while back to replace my old screen). With the newly flashed SD card this kind of boots up, it goes through a cycle, and reboots, the colors look to be all over the place.
IMG_5233.jpeg (2.48 MiB) Viewed 35615 times
IMG_5234.jpeg (2.24 MiB) Viewed 35615 times
IMG_5235.jpeg (1.86 MiB) Viewed 35615 times
IMG_5236.jpeg (3.57 MiB) Viewed 35615 times
I took every precaution in building this and really bummed it is not working right now.

Any help will be greatly appreciated.


User avatar
Posts: 39
Joined: Sat Jan 28, 2017 9:36 pm
Has thanked: 57 times
Been thanked: 20 times

Re: Circuit Sword Screen Issues.

Post by ThompsonTinkers » Wed Mar 30, 2022 10:17 am


I've recently unpacked my CSO 1.1e, and ran into the same problem. There are a few threads over in Kite's support sub-forum about this too. The short version is that there may be solder bridges on the display FPC socket or even the CM3 socket on the other side of the board.

Here's a short youtube video that shows the problem (and solution):

For my part, I think I've actually damaged my CM3. I've taped off the affected pins with kapton tape, and found a few that are stuck low, and one that is stuck high. That's not really reparable unless I can find another CM3. Rumour has it that the CM4S will be backwards compatible, but failing that I might have to bodge an SPI screen in. Until then, I guess I'm playing headless :lol:

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest