Button issue .. skip/multi press [solved]

Having trouble with your GBZ build? Ask your questions here!
Post Reply
Fixmylife
Posts: 28
Joined: Tue May 02, 2017 11:43 pm
Has thanked: 1 time
Been thanked: 3 times

Button issue .. skip/multi press [solved]

Post by Fixmylife » Thu Oct 05, 2017 7:47 pm

Whats up guys im having probelms with my gamepad the buttons skip when i press it or one click presses multiple times say i click to the left it will countinue to go to the left .. even a gentle press .. or when i click A to enter a game system it will double click and enter the first game in the list .. im using Leonardo Pro Micro ATmega32U4 and a simple 10 button pcb
Also two psp analog sticks
I followed this guide
http://www.sudomod.com/forum/viewtopic.php?f=22&t=1766

At first buttons were working great when i didnt use them with analog sticks .. then after a while i start led getting trouble with them in games they work just fine maybe theres away to add a small pause between clicks when in emulation station.
Ive used didnt leonardo chips and 3 different gamepad pcb and no luck .. thought it mike be the wire so i changed it for a bigger gauge and still same issue... please help .. ive only see one other person in the forms with this issue
Attachments
20170917_030732_001.jpg
Current build .. raspberry pi zero .. 14 buttons hdmi screen, 3 usb ports
20170917_030732_001.jpg (1.32 MiB) Viewed 1192 times
20170909_231736.jpg
20170909_231736.jpg (2.55 MiB) Viewed 1192 times
20170910_103535.jpg
20170910_103535.jpg (2.23 MiB) Viewed 1192 times
20170909_231751.jpg
20170909_231751.jpg (2.65 MiB) Viewed 1192 times
Last edited by Fixmylife on Mon Oct 09, 2017 10:13 pm, edited 1 time in total.

User avatar
Zmoneyrecords
Posts: 55
Joined: Tue Aug 22, 2017 9:39 pm
Has thanked: 10 times
Been thanked: 5 times

Re: Button issue .. skip/multi press if anyone knows solution help

Post by Zmoneyrecords » Fri Oct 06, 2017 10:51 am

Check the thread labeled "Very glitchy controls" they have the same problem and helder gave a solution

Fixmylife
Posts: 28
Joined: Tue May 02, 2017 11:43 pm
Has thanked: 1 time
Been thanked: 3 times

Re: Button issue .. skip/multi press [solved]

Post by Fixmylife » Mon Oct 09, 2017 10:20 pm

For anyone who finds this page .. this issue has been fixed thanks to a extra line added to the code
From @salami738
Here is the original post
http://www.sudomod.com/forum/viewtopic. ... 270#p46591
Attachments
20171009_204859.jpg
20171009_204859.jpg (3.56 MiB) Viewed 1145 times
Screenshot_20171010-001050.png
Screenshot_20171010-001050.png (159.63 KiB) Viewed 1145 times

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest