Sudden low voltage issues

Having trouble with your GBZ build? Ask your questions here!
Post Reply
User avatar
X..
Posts: 41
Joined: Sat Aug 11, 2018 5:57 pm
Has thanked: 11 times
Been thanked: 27 times
Contact:

Sudden low voltage issues

Post by X.. » Tue Apr 16, 2019 7:38 pm

So Ive recently migrated the internals of one of my pocket builds to another case using all of the same components and suddenly I have a constant low voltage warning Icon.

There are points when the system will shutdown because of this issue also. its a massive bummer. Ive already run through my head some reasons, but Im coming up with nothing substantial.

Specs:
Raspberry Pi 3A+
3.5in screen run via composite
Powerboost 1000C
Teensy LC
Audio Booster

The only changes Ive had to make: My screen was having issues turning on because of insufficient power when moving to the new case, so I replaced that wire with a 22AWG one. Not sure if this has to do with the moving of the crystal thing on the driver board or not, but it had to be moved to fit the shell together nicely.

I also flipped my RPi3 board around and the power switch is located to a new area and directly glued to the RPi board now and I think I forgot to use kapton tape between the two but I didnt think there was much to short out so I didnt give it much thought.

Everything else is identical.

Anyone have any ideas? Suggestions?

Also here is an image of the build, its pretty cool aside from the issue I am suddenly having.
Image
My build Progress and Designs updated on my Instagram: https://www.instagram.com/tymarbry/?hl=en
Upcoming Build Tutorials on my Youtube: https://www.youtube.com/channel/UCI96Xu ... lPs7hWdRwQ

User avatar
VeteranGamer
Posts: 1703
Joined: Thu Jan 26, 2017 11:12 am
Location: London, UK
Has thanked: 498 times
Been thanked: 883 times

Re: Sudden low voltage issues

Post by VeteranGamer » Wed Apr 17, 2019 3:18 am

this may not be of much help....

but I'm always personally dubious, when people claim that the PowerBoost is really capable of powering a RPi3 build without any issues.....

the RPi3... be it the 3B, 3B+ or the 3A+ does state (this is coming from the manufacturers) that it requires a decent power source
on paper the PowerBoost isnt that decent power source.....

when you throw in a.....
5V powered screen
5V powered micro controller (teensy or pro micro)
5V powered audio device

thats maybe expecting a bit much from the PowerBoost.....



Now some may have had success (their own claims)....

I am also taking into account, that you have just transplanted this from another build, which may not have had any issues....

But the best option is to get a decent power source, especially if you don't want any issues, or even don't want that lightening bolt flashing...


the other option would be to slim down that power draw (if you still want to stick with the PowerBoost).....
maybe opt for...
SPI LCD that you can run off the 3.3v (may not be ideal for your current build)
have the controls via the GPIO, especially if your not intending/planning on using a analog stick (a teensy isnt really needed)
have PWM audio, or go for i2S audio (which sounds a lot better than PWM)



NB: take everything with a pinch of salt as I have 0% technical know how... these are just MHO (my 2 cents as they say)





.

User avatar
tinkerBOY
Posts: 702
Joined: Tue May 30, 2017 4:00 am
Has thanked: 294 times
Been thanked: 200 times

Re: Sudden low voltage issues

Post by tinkerBOY » Wed Apr 17, 2019 7:11 am

Those parts you mentioned are just too much for the Powerboost 1000c to handle. You need a boost converter that can output more juice like the Helder's RetroPSU.
New! tinkerBOY PowerSwitch v1.0 with Safe Shutdown
Game Boy Zero Controllers available @ tinkerBOY.xyz * Support
tinkerBOY Controller v3.0 - built-in usb controller, usb audio, and usb hub
tinkerBOY Controller v2.0 - GPIO buttons and builtin PWM Audio and Amplifier
tinkerBOY Controller v1.1 - simple pcb button
* DPI Adapter - better display for GBZ
* keyboard converters - IBM XT/AT Soarer's Converter | ADB to USB Converter

User avatar
rodocop
Posts: 1636
Joined: Mon Aug 22, 2016 3:14 pm
Location: Saskatchewan
Has thanked: 595 times
Been thanked: 580 times

Re: Sudden low voltage issues

Post by rodocop » Wed Apr 17, 2019 9:27 am

Seems to be the powerboost isn't enough to power all that. I second the Helder RetroPSU option. I easily powered a pi3b+, 7" HDMI screen, USB Encoder, and a i2s Audio hat.

User avatar
X..
Posts: 41
Joined: Sat Aug 11, 2018 5:57 pm
Has thanked: 11 times
Been thanked: 27 times
Contact:

Re: Sudden low voltage issues

Post by X.. » Wed Apr 17, 2019 11:55 am

Man it may be that the powerboost just cant handle the workload, but I had all of these systems working well before the transition.
Probably need to just pick me up another Helder PSU and call it a day.

But its a good idea to consider forgoing the teensy LC and just route my controls to the RP GPIO pins instead.
Thanks all for the input.
My build Progress and Designs updated on my Instagram: https://www.instagram.com/tymarbry/?hl=en
Upcoming Build Tutorials on my Youtube: https://www.youtube.com/channel/UCI96Xu ... lPs7hWdRwQ

User avatar
infinitLoop
Posts: 381
Joined: Mon Dec 24, 2018 11:46 am
Has thanked: 162 times
Been thanked: 129 times
Contact:

Re: Sudden low voltage issues

Post by infinitLoop » Wed Apr 17, 2019 1:23 pm

i'd try a different screen, like the spi approach veteran suggested. i had a ton of power issues on a 3a+ build, and finally narrowed it to the composite screen (one of the bw variants - a gearbest was moderately better). similar thing happened to me where it was working with the same components, and moving things around suddenly brought the problems out.

seems like people that get these a+ builds working well, do the spi screen, so that's my plan for mine too.

User avatar
X..
Posts: 41
Joined: Sat Aug 11, 2018 5:57 pm
Has thanked: 11 times
Been thanked: 27 times
Contact:

Re: Sudden low voltage issues

Post by X.. » Thu Apr 18, 2019 8:23 pm

Never done an SPI screen setup before but I love the plug and play of the composite, the downside is you get lots of fuzzyness.

I have a few DPI boards that I can use maybe Ill try one of those next, but as for an actual update:
I have switched to Helder's PSU and it is kicking some ass now. no power issues and random shutdowns due to overload.
My build Progress and Designs updated on my Instagram: https://www.instagram.com/tymarbry/?hl=en
Upcoming Build Tutorials on my Youtube: https://www.youtube.com/channel/UCI96Xu ... lPs7hWdRwQ

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest