Pi won't power up with screen connected, worked previously, help pls! [SOLVED]

Having trouble with your GBZ build? Ask your questions here!
mrsippy
Posts: 17
Joined: Sun Mar 24, 2019 11:44 am
Has thanked: 14 times
Been thanked: 2 times

Pi won't power up with screen connected, worked previously, help pls! [SOLVED]

Post by mrsippy » Sun May 19, 2019 6:33 am

I successfully connected my variant 12 screen to my Pi Zero some time back, then put the (connected) bits in a box to resume work at a later stage once other components I was waiting on arrived.

Today I took the screen and Pi out of said box, and the black wire from the screen controller, which I'd soldered (not very well, evidently) to GPIO pin 6 (ground) on the Pi, came away from the Pi.

I soldered the wire back to GPIO pin 6, and plugged my Pi into the power, but it wouldn't power up - no green light, just nothing happening.

So I removed the black wire from GPIO pin 6, connected the power, and the Pi powered up, but obviously the screen didn't come on. So I unplugged the power, soldered the black wire back to the Pi, connected the power again, and again the Pi wouldn't power up.

So everything is connected in the same way as before, when it was working, but now it doesn't work, and I've no idea why.

I assume this suggests a problem with the screen, but I'm quite new to this sort of thing. Do I need to buy a new screen?

Thanks in advance.
Last edited by mrsippy on Tue May 21, 2019 4:15 pm, edited 1 time in total.

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2679
Joined: Thu May 05, 2016 8:33 am
Location: Fall River, MA
Has thanked: 1378 times
Been thanked: 3038 times

Re: Pi won't power up with screen connected, worked previously, help pls!

Post by Helder » Sun May 19, 2019 5:42 pm

Tells me you are probably grounding the wrong pin. Does the LCD power on without the Pi attached? To rule it's the LCD board that might be the issue.

Pictures help of where you're soldering to and a general look of the area helps
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

mrsippy
Posts: 17
Joined: Sun Mar 24, 2019 11:44 am
Has thanked: 14 times
Been thanked: 2 times

Re: Pi won't power up with screen connected, worked previously, help pls!

Post by mrsippy » Mon May 20, 2019 1:50 am

Thanks for your response Helder. As I mentioned in my post everything is connected as it was previously, and it was working previously.

Pic of wiring: Image

Evidence of this setup working previously: Image

Yellow wire goes to "TV" on the Pi, the green is grounded next to the pin next to it. The red wire goes to GPIO pin 2, and the black is grounded on GPIO pin 6.

User avatar
tinkerBOY
Posts: 649
Joined: Tue May 30, 2017 4:00 am
Has thanked: 276 times
Been thanked: 182 times

Re: Pi won't power up with screen connected, worked previously, help pls!

Post by tinkerBOY » Mon May 20, 2019 3:27 am

Try desoldering the green wire from the Pi and power it on.
Game Boy Zero Controllers available @ tinkerBOY.xyz
tinkerBOY Controller v3.0 - built-in usb controller, usb audio, and usb hub
tinkerBOY Controller v2.0 - GPIO buttons and builtin PWM Audio and Amplifier
tinkerBOY Controller v1.1 - simple pcb button
* DPI Adapter - better display for GBZ
* keyboard converters - IBM XT/AT Soarer's Converter | ADB to USB Converter

mrsippy
Posts: 17
Joined: Sun Mar 24, 2019 11:44 am
Has thanked: 14 times
Been thanked: 2 times

Re: Pi won't power up with screen connected, worked previously, help pls!

Post by mrsippy » Mon May 20, 2019 4:30 am

tinkerBOY wrote:
Mon May 20, 2019 3:27 am
Try desoldering the green wire from the Pi and power it on.
Thank you so much for your response, I was not expecting to hear from an absolute LEGEND :D

I tried what you suggested, but unfortunately it's still not powering on.

The strangest thing about this is that it was all working previously.

I took the opportunity to take some new pictures of what I've got going on. Please excuse my shoddy soldering, I've never done it before!

Underside of Pi showing black soldered to Pin 6: Image

Top of Pi showing red soldered to Pin 2, yellow soldered to "TV": Image

Display controller with 5V mod: Image

mrsippy
Posts: 17
Joined: Sun Mar 24, 2019 11:44 am
Has thanked: 14 times
Been thanked: 2 times

Re: Pi won't power up with screen connected, worked previously, help pls!

Post by mrsippy » Mon May 20, 2019 4:32 am

Could it be that the cable between the display controller and the display has become damaged? Things may have shifted in the box when I've moved it around over the past 6 weeks. Would that possibly cause this sort of behaviour?

User avatar
rodocop
Posts: 1596
Joined: Mon Aug 22, 2016 3:14 pm
Location: Saskatchewan
Has thanked: 576 times
Been thanked: 571 times

Re: Pi won't power up with screen connected, worked previously, help pls!

Post by rodocop » Mon May 20, 2019 7:14 am

Your yellow display wire is in the wrong place. Solder it to the square pinhole beside where it is currently.

But if your pi is not booting (no green light), there might be another issue. Have you changed anything with the sd card? Also note, you need to have the sd card inserted for anything to power on.

Have you disconnect the screen completely. And plugged the pi into a TV or something to test if it works.
Last edited by rodocop on Mon May 20, 2019 7:31 am, edited 2 times in total.

User avatar
rodocop
Posts: 1596
Joined: Mon Aug 22, 2016 3:14 pm
Location: Saskatchewan
Has thanked: 576 times
Been thanked: 571 times

Re: Pi won't power up with screen connected, worked previously, help pls!

Post by rodocop » Mon May 20, 2019 7:21 am

It's misleading, but the pin beside the TV label is actually ground. Its needs to go in the circled area seen below

Image

mrsippy
Posts: 17
Joined: Sun Mar 24, 2019 11:44 am
Has thanked: 14 times
Been thanked: 2 times

Re: Pi won't power up with screen connected, worked previously, help pls!

Post by mrsippy » Mon May 20, 2019 10:46 am

rodocop wrote:
Mon May 20, 2019 7:21 am
It's misleading, but the pin beside the TV label is actually ground. Its needs to go in the circled area seen below

Image
Thanks rodocop, I will try that as soon as I get a chance.

The Pi powers up if I disconnect the black cable from the display controller, but obviously this means I am without a working display. I can tell it is powering up because of the flashing and then steady green light on the Pi. With the black cable connected, when I plug the power in there is no green light and the display does not power up either.

mrsippy
Posts: 17
Joined: Sun Mar 24, 2019 11:44 am
Has thanked: 14 times
Been thanked: 2 times

Re: Pi won't power up with screen connected, worked previously, help pls!

Post by mrsippy » Mon May 20, 2019 11:11 am

I think the key takeaway is that it was working. Now it doesn't work, unless I disconnect the black cable from the display controller.

This suggests to me that there is a problem with the display controller, but I'm not very experienced with this sort of thing.

Guess I'm gonna have to buy another display, but am obviously open to any further suggestions, thanks to all who have helped so far.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest