Audio issue

Having trouble with your GBZ build? Ask your questions here!
Post Reply
User avatar
skrapps914
Posts: 184
Joined: Sat May 28, 2016 8:14 pm
Has thanked: 63 times
Been thanked: 33 times

Audio issue

Post by skrapps914 » Wed Aug 21, 2019 5:53 am

Hey all its been a while. I updated my retropie version, and now i cannot seem to get the audio to come out through the speaker. however it will come out through the hdmi. i have gone into audio settings and tried adjusting the volume, tried auto, tried selecting the jack, and nothing still. is there something im missing? do i have to edit a configuration to enable the audio somewhere?

thanks

User avatar
tinkerBOY
Posts: 699
Joined: Tue May 30, 2017 4:00 am
Has thanked: 293 times
Been thanked: 199 times

Re: Audio issue

Post by tinkerBOY » Wed Aug 21, 2019 9:47 pm

Im assuming it was working before the update? Is it a usb audio or PWM audio?
New! tinkerBOY PowerSwitch v1.0 with Safe Shutdown
Game Boy Zero Controllers available @ tinkerBOY.xyz * Support
tinkerBOY Controller v3.0 - built-in usb controller, usb audio, and usb hub
tinkerBOY Controller v2.0 - GPIO buttons and builtin PWM Audio and Amplifier
tinkerBOY Controller v1.1 - simple pcb button
* DPI Adapter - better display for GBZ
* keyboard converters - IBM XT/AT Soarer's Converter | ADB to USB Converter

User avatar
skrapps914
Posts: 184
Joined: Sat May 28, 2016 8:14 pm
Has thanked: 63 times
Been thanked: 33 times

Re: Audio issue

Post by skrapps914 » Mon Sep 02, 2019 6:43 pm

tinkerBOY wrote:
Wed Aug 21, 2019 9:47 pm
Im assuming it was working before the update? Is it a usb audio or PWM audio?
it is pwm audio.

User avatar
infinitLoop
Posts: 372
Joined: Mon Dec 24, 2018 11:46 am
Has thanked: 156 times
Been thanked: 126 times
Contact:

Re: Audio issue

Post by infinitLoop » Tue Sep 03, 2019 9:33 am

skrapps914 wrote:
Wed Aug 21, 2019 5:53 am
Hey all its been a while. I updated my retropie version, and now i cannot seem to get the audio to come out through the speaker. however it will come out through the hdmi. i have gone into audio settings and tried adjusting the volume, tried auto, tried selecting the jack, and nothing still. is there something im missing? do i have to edit a configuration to enable the audio somewhere?

thanks
you do need to make sure it is enabled in the /boot/config.txt file (you can edit it on the sdcard directly from a computer if you can't get into the pi's terminal).

make sure you at least have the first lines below, the last two are optional, but might get you better sound quality (these assume you are using the standard pins 18 and/or 13)

Code: Select all

dtparam=audio=on

#stereo
dtoverlay=pwm-2chan,pin=18,func=2,pin2=13,func2=4
#mono
#dtoverlay=pwm,pin=18,func=2
#alt mono
#dtoverlay=pwm,pin=13,func2=4

disable_audio_dither=1
audio_pwm_mode=0
if it was working before, i would expect it to still work, but maybe there is a similar issue to the composite-out problem with 4.5

.

User avatar
skrapps914
Posts: 184
Joined: Sat May 28, 2016 8:14 pm
Has thanked: 63 times
Been thanked: 33 times

Re: Audio issue

Post by skrapps914 » Wed Sep 11, 2019 9:15 am

thanks!

GrainBoy
Posts: 11
Joined: Mon Jan 28, 2019 4:40 pm
Has thanked: 2 times
Been thanked: 1 time

Re: Audio issue

Post by GrainBoy » Wed Sep 11, 2019 4:26 pm

I'm having audio issues as well but only when I load a rom, works in menu.

I'm using Kites CS. USB audio I believe.

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2769
Joined: Thu May 05, 2016 8:33 am
Location: Fall River, MA
Has thanked: 1407 times
Been thanked: 3075 times

Re: Audio issue

Post by Helder » Wed Sep 18, 2019 1:53 pm

GrainBoy wrote:
Wed Sep 11, 2019 4:26 pm
I'm having audio issues as well but only when I load a rom, works in menu.

I'm using Kites CS. USB audio I believe.
Try posting in Kite's support subforum for a quicker answer.


viewforum.php?f=51
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest