Page 1 of 1

[Solved] gearbest screen help please!

Posted: Mon Dec 16, 2019 3:27 am
by chewieisawookie
Hi Im unable to get any sign of life out of my gearbest screen, is there anything wrong with how Ive got it wired up? Ive tried using the yellow and the white wire but no success with either.

I tried to alter the config.txt but that didnt help either - although my understanding (possibly incorrect) is that the pi will output to the gearbest screen as long as it doesnt detect an HDMI connection?

Im getting 5v on the red wire, and about 0.3v on the white wire-does that sound right?
20191216_095952.jpg
20191216_095952.jpg (1.87 MiB) Viewed 315 times
Any help would be gratefully appreciated

Re: gearbest screen help please!

Posted: Mon Dec 16, 2019 8:52 pm
by rodocop
White or yellow shouldn't matter. I always use yellow though.

Do you have a SD card with retropi in the pi? Without a proper image the screen will not power on.

You're also right, there is no settings that need to be added or removed from the config.txt

You could also try powering the screen from another source. Rather than the pi, see if it makes a difference.

Re: gearbest screen help please!

Posted: Tue Dec 17, 2019 4:37 am
by chewieisawookie
Thanks Rodocop, Ive got an sd card with an image in and it works fine if ive got hdmi plugged in so now issues there.

I connected a 9v battery to the gearbest screen and used the signal from a Nintendo Wii and it worked fine so I know the screen is ok.

I then disconnected the battery and used the pi zero as the power source-still using the signal from the Wii, this time the screen would flicker continually between a black screen and the signal from the Wii.

This made me the think the version of the gearbest screen that Ive got is needing more than 5v?

However when I tried to connect my pizero up again this morning the pi is getting quite warm and there’s no led light on and no picture even on hdmi so think I might’ve fried it! :oops:

Could the signal from the wii have back fed voltage to the pi, even though the wii signal was only connected to the screen?
I did use a different phone charger to the one I normally use so that’s also a possible cause

[Solved] Re: gearbest screen help please!

Posted: Sun Dec 22, 2019 10:42 am
by chewieisawookie
Worked out what the problem was-Id bought an additional JST connector with cable off ebay as I hadnt wanted to chop up the cable that came with the screen however the wiring on that JST was black, red , white, yellow whereas the jst connector the came with the screen was red, black, white, yellow! Id assumed the wiring order would be a standard order.
So there you go, lesson learned - never assume!