Circuit Sword Analog Volume Wheel

Post Reply
User avatar
demodummy
Posts: 44
Joined: Thu Jul 06, 2017 9:47 am
Has thanked: 42 times
Been thanked: 10 times

Circuit Sword Analog Volume Wheel

Post by demodummy » Fri Feb 08, 2019 11:25 pm

Hi guys!

I finally got around to building my first Circuit Sword! Yay! But I have a BUNCH of questions!

Before I get started, I want to say that, despite the challenges that come with making these amazing handhelds, it really is a blast to partake in it. The problem solving, the learning, the community here and the mods who guide us through the darkness are all reasons why I’m addicted to this forum. I just want to say thanks; I haven’t had this much fun in a long time :)

Also, Kite is an awesome dude! His products are great and he’s really easy to work with. I will be buying from him for very very long time :)

Okay, enough of the fuzzy feelings. Here we go:

Till now I had not built anything since Kite’s SAIO (the last version before he started making the Circuit Sword line) which I thoroughly enjoyed for hundreds of hours until I gave it to my brother as a gift for Christmas.

Overall, I’m very satisfied with how it turned out; for all intents and purposes, my Circuit Sword is fully functional. I have, however, ran into a few walls that are stopping me from customizing it to make it truly my own.

Really the only feature I want to add on is the analog volume control. In trying to get it to work, I realized that I actually don't know much about what I’m doing. This is especially so with the Raspberry Pi/Linux interface. I mean, I’ve been pretty proud of how much I’ve been able to get by with what little knowledge I have, but I’m at the point where I need help from the pros.

Here’s where I’m at according to Circuit Sword FAQ for enabling analog volume:
  • Connect 3 pin connector on backboard to main board. DONE!
  • Enable SSH. Never did that before, how hard could it be? Google it and DONE!
  • Check that the Circuit Sword is connected to Wifi. Mode button shows that the wifi is on, just not connected.
  • I go to Wifi in the Retropie menu to connect it, but I’m hit with a prompt that says the Wifi will be disabled until I set a country….hmm… this is new. It says to launch raspi-config and check localization options… okay
  • Launch raspi-config, and head over to localization options… wtf is all this?
  • There’s Change Locale, Change Timezone, Change Keyboard Layout, and Change Wifi Country… Change Wifi Country has to be it, right?
  • Change Wifi Country leads to… No wireless interface found. The hell?
  • I go back and check the other options aside from keyboard layout, and it’s just as confusing.
I’m officially stuck and can’t move forward, haha! Any help on this is greatly appreciated!

Bonus Questions!

The mode button the Circuit Sword sometimes shows my temperature readout above
60 degrees with a flame icon next to it. I feel the fan trigger on and it does get a little warm? But I figure that’s normal. At what temperature should I be worried?

Thanks again in advance! Also, here’s a couple of pictures of how my Circuit Sword came out :)
SpoilerShow
20190208_185603.jpg
20190208_185603.jpg (2.93 MiB) Viewed 179 times
SpoilerShow
20190208_185049.jpg
20190208_185049.jpg (3.39 MiB) Viewed 179 times

User avatar
kite
Posts: 606
Joined: Thu May 12, 2016 4:30 am
Location: UK
Has thanked: 189 times
Been thanked: 244 times
Contact:

Re: Circuit Sword Analog Volume Wheel

Post by kite » Sun Feb 10, 2019 3:17 am

Hey :) as you have already worked out, the flame icon means that the fan has been enabled and should bring it back down to 50 or 55*C. Nothing to worry there, it's doing its job perfectly!

I think everything you have done is good, you can just press 'NO' to the wifi country thing, it's not required and often if you set it, it messes up a bit.. has the icon at the top always been an "X" symbol? That means "you've enabled the wifi combo, but the wifi module wasn't detected as existing" .. if it turns to a "!" that means "you've enabled the wifi combo, the module is detected, but you're not connected to an AP".

If you have a spare SD card, it would be good to image the latest version of the software and boot it up. If you still get the "X" then there is perhaps a hardware issue with the wifi module. Steps to diagnose will be to open it up and check the wifi chip, make sure it's got kapton tape over it, and none of the components have been chipped off (maybe send a pic here).

EDIT: Also, top tip, you can do the analog volume steps with a USB keyboard. Plug it into the USB port and press "F4" to drop to the shell, from here you can continue as if you were in SSH :) just on a much smaller screen!

User avatar
demodummy
Posts: 44
Joined: Thu Jul 06, 2017 9:47 am
Has thanked: 42 times
Been thanked: 10 times

Re: Circuit Sword Analog Volume Wheel

Post by demodummy » Sun Feb 10, 2019 11:28 am

Hey Kite!

Thanks as always! Once again, you've come through in fine style :) I was able to enable my volume wheel and it works great! You're the best!

I'm not too worried about the wifi; I thought I needed it to access the volume wheel capability. Sometimes it flip flops from showing the X to the ! but in the end I didn't really need it to get what I wanted working. I ended up using the keyboard method you suggested to access where I needed to go and it worked as you said it would! :)

So my temperature does spike up to 60 degrees at times but I've never seen it go past 65 degrees.... at least not yet that is. Also, my fan isn't directly placed on the module. I opted to have it attached to the cartridge area which vents out the top, like many other builds I've seen here on the forum (pictures from my first post can be seen for reference). So I'm assuming that's why it maybe goes a bit above 55 at times.

This temperature is still acceptable yes?

User avatar
kite
Posts: 606
Joined: Thu May 12, 2016 4:30 am
Location: UK
Has thanked: 189 times
Been thanked: 244 times
Contact:

Re: Circuit Sword Analog Volume Wheel

Post by kite » Sun Feb 10, 2019 11:57 am

Great glad to hear! :)

That's perfectly fine. The Pi itself is programmed that when it hits approx 80*C it will throttle back to 600MHz (default is 1200MHz). This means that you're well below that level so nothing to worry about at all! I chose that temperature to trigger the fan because it wasn't so low that it would 'always be on' and it's at a good level of comfort (for the electronics anyway).

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests