[solved] Sound on Startup / Switching WiFi off

User avatar
YaYa
Posts: 1719
Joined: Mon Jun 26, 2017 12:42 pm
Location: brittany - France
Has thanked: 871 times
Been thanked: 688 times
Contact:

Re: [partially solved] Sound on Startup / Switching WiFi off

Post by YaYa » Mon Jan 08, 2018 2:51 am

I’m really surprised because i have retropie 4.3, latest Kite’s image and a SAIO and i have sound in the splashscreen.

Don’t know why you have this issue, looks like something else but can’t figure out what’s wrong
Follow me on instagram Image

User avatar
YaYa
Posts: 1719
Joined: Mon Jun 26, 2017 12:42 pm
Location: brittany - France
Has thanked: 871 times
Been thanked: 688 times
Contact:

Re: [partially solved] Sound on Startup / Switching WiFi off

Post by YaYa » Mon Jan 08, 2018 2:55 am

After reading kite’s post that i have missed, it may be a problem with the alsa config file. Maybe you should dig in that direction.
Follow me on instagram Image

User avatar
Codemaster123
Posts: 55
Joined: Sun Sep 10, 2017 3:03 pm
Has thanked: 6 times
Been thanked: 5 times

Re: [partially solved] Sound on Startup / Switching WiFi off

Post by Codemaster123 » Mon Jan 08, 2018 3:07 am

YaYa wrote:
Mon Jan 08, 2018 2:55 am
After reading kite’s post that i have missed, it may be a problem with the alsa config file. Maybe you should dig in that direction.
if your project is working
can you post your config file to reference

User avatar
starmagoo
Posts: 70
Joined: Mon Mar 27, 2017 1:56 pm
Location: Germany
Has thanked: 69 times
Been thanked: 8 times
Contact:

Re: [partially solved] Sound on Startup / Switching WiFi off

Post by starmagoo » Mon Jan 08, 2018 4:24 am

Codemaster123 wrote:
Mon Jan 08, 2018 3:07 am
can you post your config file to reference
I'll check mine later after the update

User avatar
starmagoo
Posts: 70
Joined: Mon Mar 27, 2017 1:56 pm
Location: Germany
Has thanked: 69 times
Been thanked: 8 times
Contact:

Re: [partially solved] Sound on Startup / Switching WiFi off

Post by starmagoo » Mon Jan 08, 2018 2:18 pm

I have my solution. Somewhere between Kite's RetroPie version 4.3.x and the latest setup-script/update process, the file "/etc/init.d/asplsashscreen" moved to "/opt/retropie/supplementary/splashscreen/asplashscreen.sh".

At the new position in the line "omxplayer -o both -b --layer 10000 "$line"" you have to change from "both" to "alsa". Since then I have sound on boot, but I don't have sound from the preview. 8-)

I'm good enough for now. Maybe someone will find a solution to the sound problem in the preview.

User avatar
YaYa
Posts: 1719
Joined: Mon Jun 26, 2017 12:42 pm
Location: brittany - France
Has thanked: 871 times
Been thanked: 688 times
Contact:

Re: [solved] Sound on Startup / Switching WiFi off

Post by YaYa » Mon Jan 08, 2018 2:20 pm

Ohhh great find !
Inwould never have spotted the directory change, damn
Follow me on instagram Image

User avatar
starmagoo
Posts: 70
Joined: Mon Mar 27, 2017 1:56 pm
Location: Germany
Has thanked: 69 times
Been thanked: 8 times
Contact:

Re: [solved] Sound on Startup / Switching WiFi off

Post by starmagoo » Mon Jan 08, 2018 2:46 pm

It's just weird that you're still okay. Maybe the script was simply moved/copied with your changes to the new position? :D

I am happy to have found the solution on my own.

User avatar
Codemaster123
Posts: 55
Joined: Sun Sep 10, 2017 3:03 pm
Has thanked: 6 times
Been thanked: 5 times

Re: [solved] Sound on Startup / Switching WiFi off

Post by Codemaster123 » Mon Jan 08, 2018 11:51 pm

starmagoo wrote:
Mon Jan 08, 2018 2:46 pm
It's just weird that you're still okay. Maybe the script was simply moved/copied with your changes to the new position? :D

I am happy to have found the solution on my own.
this i try, no success
maybe i need to try refresh install

when you change to alsa, you also change on retropie sounds setting or you leave as both in setting

thx

User avatar
starmagoo
Posts: 70
Joined: Mon Mar 27, 2017 1:56 pm
Location: Germany
Has thanked: 69 times
Been thanked: 8 times
Contact:

Re: [solved] Sound on Startup / Switching WiFi off

Post by starmagoo » Tue Jan 09, 2018 3:31 am

Codemaster123 wrote:
Mon Jan 08, 2018 11:51 pm
this i try, no success
maybe i need to try refresh install

when you change to alsa, you also change on retropie sounds setting or you leave as both in setting

thx
I had already updated RetroPie completely before and at the end only changed the line from "both" to "alsa".

User avatar
YaYa
Posts: 1719
Joined: Mon Jun 26, 2017 12:42 pm
Location: brittany - France
Has thanked: 871 times
Been thanked: 688 times
Contact:

Re: [solved] Sound on Startup / Switching WiFi off

Post by YaYa » Tue Jan 09, 2018 3:34 am

Maybe the problem is the update process. In my case, i was using a fresh new 4.3 image in which Kite did add his stuff, so the files were directly in the good folders i presume.
Follow me on instagram Image

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest