(Probably resolved) Yellow tint and banding on screen sword lite

Post Reply
Tomatopaste
Posts: 8
Joined: Thu Dec 14, 2017 1:02 pm
Has thanked: 1 time
Been thanked: 1 time

(Probably resolved) Yellow tint and banding on screen sword lite

Post by Tomatopaste » Fri Oct 12, 2018 9:38 am

***** might have done got it... sorry.
Looks like alcohol was the solution...
cleaned all the contacts and we look 100% better

**********
So my screen has a yellow tinge to it in certain screens and some horizontal banding issues very similar to the issue I see on the cm3 sword.
My eyes aren’t the best but I can not (at least easily) see any bridges on the ribbon connector on the board.
Any ideas to help me out?
Thanks!

** edit
Now I can not get a pic of it.... will look more in a bit sorry at work and break time is over

Love the product Kite!!! Cheers and I will try to get you better info when I can.
Thanks
Last edited by Tomatopaste on Sun Oct 14, 2018 8:05 pm, edited 2 times in total.

Tomatopaste
Posts: 8
Joined: Thu Dec 14, 2017 1:02 pm
Has thanked: 1 time
Been thanked: 1 time

Re: Yellow, artifacting screen sword lite

Post by Tomatopaste » Fri Oct 12, 2018 10:19 am

Here are a couple shots...
The menu is static so it’s eaiser to get a clean pic.
Attachments
CEA0133D-E849-4AA3-8FB9-61131939F264.jpeg
CEA0133D-E849-4AA3-8FB9-61131939F264.jpeg (3.25 MiB) Viewed 224 times
5E7342C6-4FA3-4578-8E5A-9A0898994160.jpeg
5E7342C6-4FA3-4578-8E5A-9A0898994160.jpeg (4.2 MiB) Viewed 224 times

Tomatopaste
Posts: 8
Joined: Thu Dec 14, 2017 1:02 pm
Has thanked: 1 time
Been thanked: 1 time

Re: Yellow tint and banding on screen sword lite

Post by Tomatopaste » Sun Oct 14, 2018 9:03 am

Are there any troubleshooting steps you would like me to make Kite?
I can try to flux it and tap with a soldering iron like in the video in your troubleshooting guide I just don’t want to make it worse and have no further recourse.

Thanks.

User avatar
kite
Posts: 1751
Joined: Thu May 12, 2016 4:30 am
Location: UK
Has thanked: 385 times
Been thanked: 2148 times
Contact:

Re: (Probably resolved) Yellow tint and banding on screen sword lite

Post by kite » Mon Oct 22, 2018 3:20 am

If you have some steps then please feel free to edit the wiki where appropriate, I do check what gets changed from time to time so i can correct it so don't worry ;) There is a section for LCD troubleshooting so perhaps there? https://github.com/kiteretro/Circuit-Sw ... leshooting

Post Reply

Who is online

Users browsing this forum: No registered users and 33 guests