Circuit Sword Lite - Audio Problems

Post Reply
duran215
Posts: 1
Joined: Wed Jul 03, 2019 1:33 pm

Circuit Sword Lite - Audio Problems

Post by duran215 » Fri Jul 05, 2019 2:48 pm

Hello All,

A question for anyone if you have the time,

I have finished Kite's Circuit Sword Lite build, using the analog volume wheel, but I can't get the audio to work at all. The message I keep getting is

1v10: VolumeControl::init() - Failed to attach to default card!
1v10: AudioManager Error - Unable to open SDL audio: ALSA: Couldn't open audio device: No such file or directory

I have made sure the USB switch is on 'internal', I have tried updating the config.txt file to read 'dtparam=audio=on', and I have tried various combinations with the sound settings with the main menu. I have also re flashed the card with the CSL software v1.0.1. Everything works great except the audio, speaker and headphone jack.

I'm not sure how to run an audio test, I feel that might be helpful as well.

An update:

I ran the software test, and I got

USB AUDIO = [FAIL]
GPIO SHDW = [ON]

Another update:

A bad solder connection to the DP (red wire) for the usb conn was the problem. It is working! thanks to kite, wermy, hoolyhoo, helder, and all the community

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest