Looking for help with audio and wifi problems with Circuit Sword.

Post Reply
TERRA Operative
Posts: 3
Joined: Tue Oct 10, 2017 12:36 am
Has thanked: 2 times

Looking for help with audio and wifi problems with Circuit Sword.

Post by TERRA Operative » Fri Aug 30, 2019 8:44 am

I have just put together my circuit sword and it all works great except two things...

After updates the internal wifi doesn't work. I saw this is due to the wifi drivers being baked into the custom circuit sword kernel?
It's no big deal as I don't use it much and have a genuine Raspi wifi dongle I can plug in to use, but is it possible to add the drivers back in myself to make the internal wifi work?


Also the audio.
The audio does work, and when I turn the analogue dial it shows the volume percent indicator as it should, but it doesn't actually adjust the volume at all, I only get 100% output at all times.

I noticed the following error is shown though:

Code: Select all

ALSA Lib control.c:1373(snd_ctrl_open_noupdate) invalid ctl both
lcl0 VolumeControl::init() - failed to attach to default card!
Can someone help me out to at least get the audio volume control working? The wifi would be nice too but not critical.

User avatar
kite
Posts: 852
Joined: Thu May 12, 2016 4:30 am
Location: UK
Has thanked: 223 times
Been thanked: 286 times
Contact:

Re: Looking for help with audio and wifi problems with Circuit Sword.

Post by kite » Fri Aug 30, 2019 12:01 pm

Do you have another SD? Can you re-image to the version on github and see if it works correctly with that?

TERRA Operative
Posts: 3
Joined: Tue Oct 10, 2017 12:36 am
Has thanked: 2 times

Re: Looking for help with audio and wifi problems with Circuit Sword.

Post by TERRA Operative » Fri Aug 30, 2019 8:22 pm

Yep, that fixed it.

In that case, what can I safely update without breaking stuff?

User avatar
kite
Posts: 852
Joined: Thu May 12, 2016 4:30 am
Location: UK
Has thanked: 223 times
Been thanked: 286 times
Contact:

Re: Looking for help with audio and wifi problems with Circuit Sword.

Post by kite » Sun Sep 01, 2019 1:32 pm

Glad to hear :) Anything other than the kernel. It usually asks "upgrade kernel?", always select 'No' (I am working on a solution for this btw)

TERRA Operative
Posts: 3
Joined: Tue Oct 10, 2017 12:36 am
Has thanked: 2 times

Re: Looking for help with audio and wifi problems with Circuit Sword.

Post by TERRA Operative » Sun Sep 01, 2019 10:32 pm

Fantastic. I think I can manage that.

Thanks for the help! :)

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest