All in One PCB Support Thread

Locked
dwark
Posts: 5
Joined: Tue Aug 09, 2016 5:54 pm

Re: All in One PCB Support Thread

Post by dwark » Thu Aug 18, 2016 3:56 pm

i just purchased an all in one board, and i was wondering if i still need the Adafruit Mono 2.5W Class D Audio Amplifier - PAM8302, im pretty sure you donmt need one but i just wanted clarification

dwark
Posts: 5
Joined: Tue Aug 09, 2016 5:54 pm

Re: All in One PCB Support Thread

Post by dwark » Thu Aug 18, 2016 3:56 pm

i just purchased an all in one board, and i was wondering if i still need the Adafruit Mono 2.5W Class D Audio Amplifier - PAM8302, im pretty sure you dont need one but i just wanted clarification

User avatar
hueblo
Posts: 175
Joined: Mon Jun 06, 2016 2:59 pm
Has thanked: 78 times
Been thanked: 81 times

Re: All in One PCB Support Thread

Post by hueblo » Thu Aug 18, 2016 3:57 pm

dwark wrote:i just purchased an all in one board, and i was wondering if i still need the Adafruit Mono 2.5W Class D Audio Amplifier - PAM8302, im pretty sure you dont need one but i just wanted clarification
You do not need it.

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2985
Joined: Thu May 05, 2016 8:33 am
Location: Rogers, AR
Has thanked: 1459 times
Been thanked: 3112 times

Re: All in One PCB Support Thread

Post by Helder » Thu Aug 18, 2016 4:20 pm

Thanks to @Brett82 for doing a few tests on his AIO and he has gotten all the devices to work numerous times and it was simply just interference from all the other components picking up on the Data Lines. He twisted the data lines and has since had no issues with wifi or anything, please give this a try @hueblo
Chat with me and other members On Discord

Don't contact me about obtaining my board files (as you will not get them). If my Boards or PCB Kits are sold out, they will be restocked as soon as I can get them and there is demand for them. You can join the mailing list on my Website to be notified when they are available.


Helder's Game Tech Website

We will not support any cloned work so don't come to us with technical issues to resolve, go talk to the cloner for help.

User avatar
hueblo
Posts: 175
Joined: Mon Jun 06, 2016 2:59 pm
Has thanked: 78 times
Been thanked: 81 times

Re: All in One PCB Support Thread

Post by hueblo » Thu Aug 18, 2016 4:27 pm

Helder wrote:Thanks to @Brett82 for doing a few tests on his AIO and he has gotten all the devices to work numerous times and it was simply just interference from all the other components picking up on the Data Lines. He twisted the data lines and has since had no issues with wifi or anything, please give this a try @hueblo
Twist the data lines to the pi0 or twist the lines to the usb port? Or both? @Brett82 are there pics? Awesome if it works.

Brett82
Posts: 52
Joined: Fri Jul 08, 2016 8:12 am
Has thanked: 17 times
Been thanked: 23 times

Re: All in One PCB Support Thread

Post by Brett82 » Thu Aug 18, 2016 4:47 pm

twist all data lines in your build eg green and whites together
USBtwisted.jpg
USBtwisted.jpg (4.55 MiB) Viewed 4534 times
Twisted pair cabling is a type of wiring in which two conductors of a single circuit are twisted together for the purposes of canceling out electromagnetic interference (EMI)
If the wires ran just parallel they would form a (narrow) loop which could pick up magnetic interference. But thanks to the twists the orientation of the wires with respect to the field changes continuously. An induced current will be cancelled by a current with the opposite sign half a twist further.
Suppose you have a disturbance working vertically on the twisted wire. You could regard each half twist as a small loop picking up the disturbance. Then it's easy to see that the next tiny loop sees the opposite field (upside down, so to speak), so that cancels the first field. This happens for each pair of half twists.

User avatar
HoolyHoo
Posts: 760
Joined: Sat Jul 09, 2016 9:34 pm
Has thanked: 206 times
Been thanked: 735 times

Re: All in One PCB Support Thread

Post by HoolyHoo » Thu Aug 18, 2016 6:03 pm

Unfortunately this solution did not work for me. I twisted all usb green and white wires including the ones leading from the pi. Only keyboard working. Has it worked for anyone else?

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2985
Joined: Thu May 05, 2016 8:33 am
Location: Rogers, AR
Has thanked: 1459 times
Been thanked: 3112 times

Re: All in One PCB Support Thread

Post by Helder » Thu Aug 18, 2016 6:29 pm

HoolyHoo wrote:Unfortunately this solution did not work for me. I twisted all usb green and white wires including the ones leading from the pi. Only keyboard working. Has it worked for anyone else?

This one has been tested and works with the twisted data line method:

https://www.adafruit.com/products/814

Also these have been tested too:

Belkin f6d4050 v2
https://www.amazon.com/BELKIN-150N-WIRE ... B0026IBI1O

TP Link TL-WN722N
https://www.amazon.com/TP-LINK-TL-WN722 ... +tl-wn722n
Chat with me and other members On Discord

Don't contact me about obtaining my board files (as you will not get them). If my Boards or PCB Kits are sold out, they will be restocked as soon as I can get them and there is demand for them. You can join the mailing list on my Website to be notified when they are available.


Helder's Game Tech Website

We will not support any cloned work so don't come to us with technical issues to resolve, go talk to the cloner for help.

Brett82
Posts: 52
Joined: Fri Jul 08, 2016 8:12 am
Has thanked: 17 times
Been thanked: 23 times

Re: All in One PCB Support Thread

Post by Brett82 » Thu Aug 18, 2016 6:31 pm

please try updating

Code: Select all

sudo apt-get update

Code: Select all

sudo apt-get dist-upgrade

Code: Select all

sudo apt-get install rpi-update

User avatar
hueblo
Posts: 175
Joined: Mon Jun 06, 2016 2:59 pm
Has thanked: 78 times
Been thanked: 81 times

Re: All in One PCB Support Thread

Post by hueblo » Thu Aug 18, 2016 8:58 pm

@holder
@Brett82

Definitely on to something. The AIO seems to be detected every time now, before it would work intermittently our would not work when audio was hooked up (haven't hooked it up since this fix). Twisted all the data wires and still having the issue. I also tried hooking up the usb hub that works to one of the usb ports off the AIO creating some kind of usb inception and it seemed to work initially but then it reacted the same. I will definitely try those other ts steps you suggested this weekend.

Locked

Who is online

Users browsing this forum: No registered users and 1 guest