Page 1 of 1

[SOLVED] Shoulder buttons not working - PocketPI FE

Posted: Wed May 08, 2019 5:18 am
by ekilla
Hi there,

I´ve found another problem I have, shoulder buttons are not working.

I´ve opened the case and got the superglued shoulder button bracket out somehow easily.
I recognized the rubber pads not sitting properly and fixed it. But the buttons still didn´t work.

First thing was to measure if the buttons are working.
There is my first problem. Are rubber pads meant to completely short the circuit?
Because I don´t get continuity when the rubbers are pressed. It´s depending on how much you press, something between 100 - 1500 Ohm
Doesn´t matter which rubber pads I use or which of my two back button boards I have tried.
That´s measured directly on the solder point of the back button board. I just put a rubber on it and press it while measuring the two solder points.

I thought it should short the circiut, but maybe that´s the way they work. I just don´t know it.

Anyways, I´ve even tried to short the to solderpoint on the main PCB to get a button press, butt nothing happens. That was just to be sure it´s not from my cables to the back board or from my soldering.

I tried to see if the buttons do something in the games list, but I´m not sure if they should do something there.
So I startet Metroid Fusion and Metroid Zero Mission on GBA. You can open the map with start and in there you can switch between map and status with "R" or go to sleep mode with "L".
But on both games nothing happens too. Looks like if I hadn´t soldered the buttons entirely, but as said even shorting the mainboard solder points does nothing.

How can I check if the buttons are set in retropie? Since I think the controlles are made using the GPIO pins I´m not sure if I can just go to emulation station settings and set it new. Or if I have to look into some file. I´m unfortunately not familiar with GPIO controls but I think I remember they are realized in a setup file.

Damn damn and audio is still not working too and I can´t find the reason. -.-
I really hope I can use it soon. It hase some glitches, but I really like this small little thingy.

I appriciate any idea to maybe solve these problems.

Re: Shoulder buttons not working - PocketPI FE

Posted: Wed May 08, 2019 1:25 pm
by ekilla
hmm I think the configuration should be ok, That´s the keys.cfg from the one-for-all software


LEFT = 26
RIGHT = 13
DOWN = 6
UP = 12
BUTTON_L1 = 16
BUTTON_R1 = 20
START = 15

Does anybody know how the conductive rubber buttons should act? I just measured them again, if the are connected to the (turned of) PocketPi FE Board, I have about 20M Ohm and when I press them I get 2k - 5k Ohm.

A always thought the rubber would short the connection and I should have abut 0 Ohm on a pressed button.

I just don´t see why they aren´t functional. And why I have no sound too.

Re: Shoulder buttons not working - PocketPI FE

Posted: Sat May 11, 2019 4:28 pm
by KonnorJ
Try cleaning the contacts with alcohol

Re: Shoulder buttons not working - PocketPI FE

Posted: Sat May 11, 2019 5:46 pm
by ekilla
Thanks Konnor, I did that before.
Now they are working, I had to configure the Buttons within retropie...