DPI screen color cycling on startup issue [SOLVED]

General GBZ-related chat goes here. Share ideas, tips and tricks, or ask questions that don't fit into the hardware/software help forums.
Post Reply
User avatar
X..
Posts: 15
Joined: Sat Aug 11, 2018 5:57 pm
Been thanked: 2 times
Contact:

DPI screen color cycling on startup issue [SOLVED]

Post by X.. » Sun Mar 10, 2019 4:25 pm

The Problem:
Just ordered in a batch of Mattc's dpi adapter boards and soldered
on the components, but im having an issue where the screen turns
on but cycles through red, green, blue, white and black, and doesnt
boot into retropie. just gets stuck on this color cycling screen.

Here is the Mattc 18bit DPI board assembly:
Image

If anyone has seen this or knows how to correct this behavior, let me know!

The Solution:
When I went back through probing with my multimeter i saw a short between
the GND and Data Enable pins that goto the FPC connector. When soldering
these very small pitched connectors, it is easy to cause a solder bridge that
causes a short.

The screen color cycles because it is not receiving a signal. Hope this can
help anyone that was in my place.
Last edited by X.. on Mon Mar 18, 2019 11:49 am, edited 5 times in total.
My build Progress and Designs updated on my Instagram: https://www.instagram.com/tymarbry/?hl=en
Upcoming Build Tutorials on my Youtube: https://www.youtube.com/channel/UCI96Xu ... lPs7hWdRwQ


User avatar
X..
Posts: 15
Joined: Sat Aug 11, 2018 5:57 pm
Been thanked: 2 times
Contact:

Re: DPI screen color cycling on startup issue

Post by X.. » Fri Mar 15, 2019 10:25 pm

I did not see that thread,
trying to narrow down this issue in the forum or even online is pretty difficult.
But it looks like that user was having temp and intermittent connectivity issues,
but mine is working fine it seems. just not displaying the output from the Pi.

I need to upload a short video of whats going on. Ive contacted Tinkerboy to
get some extra help in the situation but I think we are out of ideas for now.
My build Progress and Designs updated on my Instagram: https://www.instagram.com/tymarbry/?hl=en
Upcoming Build Tutorials on my Youtube: https://www.youtube.com/channel/UCI96Xu ... lPs7hWdRwQ

User avatar
rodocop
Posts: 1466
Joined: Mon Aug 22, 2016 3:14 pm
Location: Saskatchewan
Has thanked: 545 times
Been thanked: 531 times

Re: DPI screen color cycling on startup issue [SOLVED]

Post by rodocop » Sat Mar 16, 2019 6:12 pm

Glad you got it working. I'll have to assemble some of my boards soon. Maybe this weekend??

User avatar
X..
Posts: 15
Joined: Sat Aug 11, 2018 5:57 pm
Been thanked: 2 times
Contact:

Re: DPI screen color cycling on startup issue [SOLVED]

Post by X.. » Mon Mar 18, 2019 11:51 am

Good Luck my dude..... when it comes to those FPC connectors I am all thumbs.

Even with a chisel tip and patience it was pretty hard.
It would be nice to have a magnifying glass or a jeweler's lens to see what youre doing!
My build Progress and Designs updated on my Instagram: https://www.instagram.com/tymarbry/?hl=en
Upcoming Build Tutorials on my Youtube: https://www.youtube.com/channel/UCI96Xu ... lPs7hWdRwQ

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests