Not charging?

Post Reply
keffcat
Posts: 17
Joined: Tue May 30, 2017 10:52 am
Has thanked: 3 times
Been thanked: 1 time

Not charging?

Post by keffcat » Wed May 15, 2019 9:49 am

I finally got around to building my circuit sword. Everything works fine except charging - when I plug in a USB-C cable the LEDs all light up, the battery charging indicator appears in the top-right corner, but the battery icon never fills up - it just keeps draining.

Is this a known problem? Can I verify if my charging circuit is indeed broken?

User avatar
kite
Posts: 853
Joined: Thu May 12, 2016 4:30 am
Location: UK
Has thanked: 223 times
Been thanked: 301 times
Contact:

Re: Not charging?

Post by kite » Fri May 17, 2019 4:15 am

What does the indicator look like? A small plug symbol, or a lightning bolt symbol? Have you ever plugged the battery in the wrong way round?

keffcat
Posts: 17
Joined: Tue May 30, 2017 10:52 am
Has thanked: 3 times
Been thanked: 1 time

Re: Not charging?

Post by keffcat » Fri May 17, 2019 10:12 pm

kite wrote:
Fri May 17, 2019 4:15 am
What does the indicator look like? A small plug symbol, or a lightning bolt symbol? Have you ever plugged the battery in the wrong way round?
The indicator looks like a small plug symbol. And I've never plugged the battery in the wrong way as far as I'm aware - I've always been really careful about checking the polarity given the other horror stories I've seen on here.

User avatar
kite
Posts: 853
Joined: Thu May 12, 2016 4:30 am
Location: UK
Has thanked: 223 times
Been thanked: 301 times
Contact:

Re: Not charging?

Post by kite » Mon May 20, 2019 1:55 am

Ok, plugged symbol means plugged in but not charging, so sounds like the charging IC needs replacing. If you could send me an email I'll give you the return address and get it replaced

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest