No Sound In Game (Circuit Sword)

Post Reply
GrainBoy
Posts: 11
Joined: Mon Jan 28, 2019 4:40 pm
Has thanked: 2 times
Been thanked: 1 time

No Sound In Game (Circuit Sword)

Post by GrainBoy » Thu Sep 12, 2019 8:32 am

Hey guys. I have been at this for 2 days now..

Finally got my CS put together. Flashed Kites CS image. Set up Retropie. Transferred roms. etc.

I am not getting sound in games though. I am getting sound in menu and on splash screen, but no sound when I load a rom. So im positive the speaker works, almost certain this is a settings or config issue. I have tried literally everything I've come across online with no luck..

Config.txt :

Code: Select all

# Some settings from the orignal config.txt
gpu_mem_256=128
gpu_mem_512=256
gpu_mem_1024=256
overscan_scale=1

##########################
#### GENERIC SETTINGS ####
##########################

# Disable low voltage warning when on 3.3v
avoid_warnings=2

# Enable safe shutdown
dtoverlay=gpio-poweroff,gpiopin=39,active_low="y"

# Disable onboard audio
#dtparam=audio=on

# Enable SDIO wifi
dtoverlay=sdio,poll_once=false

# SD overclock (ONLY IF SD SUPPORTS IT)
#dtoverlay=sdtweak,overclock_50=100

# Always enable the HDMI interface
hdmi_force_hotplug=1

#### HDMI SETTINGS ####
#######################
# CS START HDMI SETTINGS

## Enable HDMI audio
#dtparam=audio=on
#hdmi_drive=2

## Disable overscan
#disable_overscan=1

## Set HDMI output to 1280x720 (720p)
hdmi_group=2
hdmi_mode=4

### Set HDMI output to 1920x1080 (1080p)
##hdmi_group=1
##hdmi_mode=16

### Set HDMI output to 800x480
##hdmi_group=2
##hdmi_mode=87
##hdmi_cvt=800 480 60 6 0 0 0

# CS END HDMI SETTINGS

#######################
#### DPI SETTINGS #####
#######################
# CS START DPI SETTINGS
# Enable DPI
dtoverlay=dpi18
overscan_left=0
overscan_right=0
overscan_top=0
overscan_bottom=0
enable_dpi_lcd=1
display_default_lcd=1
dpi_group=2
dpi_mode=87

# Enable 320x240 custom display mode
framebuffer_width=320
framebuffer_height=240
display_rotate=2
dpi_output_format=24597
hdmi_timings=320 1 20 30 38 240 1 4 3 10 0 0 0 60 0 9600000 1

# Enable 640x480 custom display mode
#framebuffer_width=640
#framebuffer_height=480
#display_rotate=3
#dpi_output_format=287269
#hdmi_timings=480 1 5 5 14 640 1 3 3 3 0 0 0 60 0 32000000 1

# CS END DPI SETTINGS

disable_splash=1
Audio Cards (cat /proc/asound/modules) :

Code: Select all

0 snd_usb_audio
Sound.conf (/etc/asound.conf) :

Code: Select all

pcm.card0 {
type hw card 0
}
ctl.card0 {
type hw card 0
}

pcm.!default card0
Alsa-base.config (/etc/modprobe.d/alsa-base.conf) :

Code: Select all

# Set both USB and HDMI to the same index so
#   that when HDMI is enabled, it takes over

options snd-usb-audio index=0
options snd_bcm2835 index=0
Only other change I've made to config is I changed the omx player to -o alsa in splashscreen.sh to get sound on my splash screen. Ive tried changing every possible option in Sound Settings, Raspi-Config settings, Retropie Set-up Settings, Audio settings, and Retroarch Audio Settings...Im at a loss.

*Im also getting a "1v10: AudioManager Error - Unable to open SDL audio: ALSA: Couldn't open audio device: Device or resource busy" in between menu loads.

User avatar
kite
Posts: 838
Joined: Thu May 12, 2016 4:30 am
Location: UK
Has thanked: 221 times
Been thanked: 280 times
Contact:

Re: No Sound (Circuit Sword)

Post by kite » Fri Sep 13, 2019 1:52 am

What exactly did you change? The config.txt looks adjusted to what it usually is.. I would first flash the image on github and make no changes and confirm sound works because it's all set up to work out of the box! If still no sound then please put it in tester mode and check the 'USB SOUND' passes the little test thing (saying [OK])

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests