[SOLVED]Possible Adafruit screen issue

Having trouble with your GBZ build? Ask your questions here!
Post Reply
oXoFearless
Posts: 2
Joined: Fri Mar 13, 2020 11:59 pm
Has thanked: 1 time
Been thanked: 1 time

[SOLVED]Possible Adafruit screen issue

Post by oXoFearless » Sun Mar 22, 2020 8:23 pm

My Adafruit NTSC/PAL TFT screen doesn't display anything while my pi zero is on. Re-soldered some wires which didn't fix the problem. While I was taking the ribbon out of the board the small black plastic bar that holds the ribbon in place broke on one side. The ribbon wasn't damaged, and the bar still pops into place to hold the ribbon. I'm not sure if that has any effect on the display. Any help would be greatly appreciated
Attachments
thumbnail5.jpg
thumbnail5.jpg (76.12 KiB) Viewed 118 times
thumbnail4.jpg
thumbnail4.jpg (177.58 KiB) Viewed 118 times
thumbnail3.jpg
thumbnail3.jpg (156.04 KiB) Viewed 118 times
thumbnail2.jpg
thumbnail2.jpg (95.15 KiB) Viewed 118 times
thumbnail.jpg
thumbnail.jpg (157.96 KiB) Viewed 118 times
Last edited by oXoFearless on Mon Mar 23, 2020 3:26 pm, edited 1 time in total.

MrErickson
Posts: 145
Joined: Sat Nov 04, 2017 3:04 pm
Has thanked: 43 times
Been thanked: 31 times

Re: Possible Adafruit screen issue

Post by MrErickson » Mon Mar 23, 2020 10:16 am

I've never used an Adafruit screen before but the first two things I'd check would be one the ribbon remains securely seated and two use a Multimeter to verify you're getting 5v to the screen board.

The plastic bar breaking shouldn't be a big deal, I've had them pop off before but still snap back in place and hold just fine, so long as that is the case I wouldn't think that is the issue.

oXoFearless
Posts: 2
Joined: Fri Mar 13, 2020 11:59 pm
Has thanked: 1 time
Been thanked: 1 time

Re: Possible Adafruit screen issue

Post by oXoFearless » Mon Mar 23, 2020 2:07 pm

Found it was not at 5v. Re-soldered and got it working. Thank you for your help!

MrErickson
Posts: 145
Joined: Sat Nov 04, 2017 3:04 pm
Has thanked: 43 times
Been thanked: 31 times

Re: [SOLVED]Possible Adafruit screen issue

Post by MrErickson » Tue Mar 24, 2020 9:26 am

Glad to hear you got it working.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest