Page 1 of 1

GPIO works in menu but not games

Posted: Thu Mar 15, 2018 7:55 pm
by Golddeenoh
I have been fighting this for days, nothing i have found tells me how to resolve it. i can move and control retropie in the game menu, reconfigure my buttons to be sure it reads them, it does, and yet i go into the game and have to use a keybaord to get the game to play/exit. i did a fresh install, redid all of the controls and had the same result.

retrogame install instructions used:
moosepr wrote:
Fri Dec 22, 2017 4:23 pm
i normally install it manually.

Code: Select all

git clone

cd Adafruit-Retrogame


sudo make install
then you need to create a file to make retrogame in the actual games

Code: Select all

sudo nano /etc/udev/rules.d/10-retrogame.rules
then inside nano you need to paste

Code: Select all

SUBSYSTEM=="input", ATTRS{name}=="retrogame", ENV{ID_INPUT_KEYBOARD}="1"
press ctrl + o to save, then ctrl + x to close

you will then need to make it run at startup, so add it into /etc/rc.local
plus putting a copy of the retrogame.cfg file in the /boot.

I have attempted the following guides to resolve it to no prevail. what piece of data am i missing to make the games work with this? ... hp?t=83579 ... 92#p589292 ... n-games/15 ... hp?t=83579

Re: GPIO works in menu but not games

Posted: Fri Mar 16, 2018 3:08 am
by moosepr
I had a major head scratching moment with the same thing. Try manually typing the code within the /etc/udev/rules.d/10-retrogame.rules file, i had issues with copy and paste actually putting the wrong characters in. It was the double quotes that got me, they looked like double quotes, but when i typed a new one next to it, it looked different.

Re: GPIO works in menu but not games

Posted: Fri Mar 16, 2018 11:40 am
by Golddeenoh
that was the issue, i had manually typed it in the first time and it seemed correct.

I had to copy the text into a plain text document, remove .txt, then drop it in BIOS on the retropie, then i used the file manager to move it the correct file and delete the old version. Probably the hard way but it worked.