Circuit sword lite - no audio from speaker

Post Reply
millski
Posts: 11
Joined: Tue Jul 18, 2017 5:07 am
Has thanked: 2 times
Been thanked: 1 time

Circuit sword lite - no audio from speaker

Post by millski » Fri Jan 10, 2020 7:35 am

Hi, I have a circuit sword lite build that I’m not getting any sound from the speaker on. I’ve attached a photo in case anybody can see anything obvious.
0808FCBB-4989-404A-8399-DF101122DFCF.jpeg
0808FCBB-4989-404A-8399-DF101122DFCF.jpeg (2.72 MiB) Viewed 571 times
Edit:
I hooked up the speaker from another lite I’ve built and know works - still no sound. I’m using the same Tetris rom on my working build and this one. I never use USB and the switch for USB is still off.

User avatar
kite
Posts: 935
Joined: Thu May 12, 2016 4:30 am
Location: UK
Has thanked: 238 times
Been thanked: 317 times
Contact:

Re: Circuit sword lite - no audio from speaker

Post by kite » Sat Jan 11, 2020 4:12 am

When run in tester mode, does the USB AUDIO test pass?

millski
Posts: 11
Joined: Tue Jul 18, 2017 5:07 am
Has thanked: 2 times
Been thanked: 1 time

Re: Circuit sword lite - no audio from speaker

Post by millski » Mon Jan 13, 2020 2:50 am

kite wrote:
Sat Jan 11, 2020 4:12 am
When run in tester mode, does the USB AUDIO test pass?
Ah no, it says 'fail' on usb audio :/

User avatar
kite
Posts: 935
Joined: Thu May 12, 2016 4:30 am
Location: UK
Has thanked: 238 times
Been thanked: 317 times
Contact:

Re: Circuit sword lite - no audio from speaker

Post by kite » Mon Jan 13, 2020 2:56 am

Check the USB wire soldering (the 3pin JST wire) and check for shorted between the soldered contacts, post pictures of that area if you'd like my feedback on it

millski
Posts: 11
Joined: Tue Jul 18, 2017 5:07 am
Has thanked: 2 times
Been thanked: 1 time

Re: Circuit sword lite - no audio from speaker

Post by millski » Mon Jan 13, 2020 3:40 am

kite wrote:
Mon Jan 13, 2020 2:56 am
Check the USB wire soldering (the 3pin JST wire) and check for shorted between the soldered contacts, post pictures of that area if you'd like my feedback on it
You sir are a legend. A small strand of wire had bridged ground and live over the usb solders and was stuck to the inside of the kapton tape. Fresh tape and all is well!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest